X11 forwarding, fake xauth

5 posts / 0 new
Last post
Meteorhead
Offline
Last seen: 7 years 11 months ago
Joined: 11.12.2012 - 17:21
X11 forwarding, fake xauth

Hi!

 

I have an issue with CopSSH where I want to ssh from a Windows Server 2012 onto a remote linux server. Problem is that it seems to me that no matter if I use -X or -Y command line option, or whether I set ForwardX11/ForwardX11Trusted/ForwardX11Agent to yes or no in ssh_config, I get the following error:

 

warning no xauth data using fake authentication data for x11 forwarding.

 

Other tools (such as BitVise) are capable of X11 forwarding, so I take it this is not an issue of the remote server setup. I suspect the problem is that there is no xauth shipping with CopSSH, thus it is no wonder the remote server cannot authenticate my Server 2012.

What is the standard way of resolving this issue?

ps.: I would not like to resort to other SSH clients, because all have uncorrectabe faults, such as BitVise completely reformatting the terminal, or MANY others not being able to translate linux terminal commands proplerly... CopSSH is closest to being THE solution, only X11 is faulty, but this seems corrigable.

itefix
Offline
Last seen: 6 hours 36 min ago
Joined: 01.05.2008 - 21:33
Copssh is OpenSSH on

Copssh is OpenSSH on Cygwin/Windows and is definitely capable of X forwarding. From Cygwin FAQ :

6.4. What does "Warning: no xauth data; using fake authentication data for X11 forwarding" mean?

Unless you started the server with the -auth option (typically by using startx) this warning is expected and can safely be ignored.

 

Meteorhead
Offline
Last seen: 7 years 11 months ago
Joined: 11.12.2012 - 17:21
I would safely ignore the

I would safely ignore the warning, but no X application can be run because it give me the error:

 

connect /tmp/.X11-unix/X0: No such file or directory

 

The file does exist, as well as X3, and root is the owner of X0, and my user is the owner of X3

itefix
Offline
Last seen: 6 hours 36 min ago
Joined: 01.05.2008 - 21:33
There are some interesting

There are some interesting Cygwin forum threads about the subject. Hva you checked ssh -X : connect /tmp/.X11-unix/X0: No such file or directory - Cygwin  for example ?


Meteorhead
Offline
Last seen: 7 years 11 months ago
Joined: 11.12.2012 - 17:21
I have not been able to solve

I have not been able to solve the issue, I ended up in the same place as the person in the linked thread. Therefor since my initial aim was solely to get an X-capable ssh client that works cleanly from a native terminal (like cmd or PS) I decided to stick with cygwin's openssh client which has ssh.exe that works like an angel from both PS and cmd and XWin.exe works well with it as an X-Server.

This is a better choice for me, although it is not native in it's true sense, it allows me to use another tool which will be very useful later on in development, namely VirtualGL which has ceased to provide a Win32 client, only the proprietary Exceed one, but it has a Cygwin client, which I couldn't get to work yet, but that is another topic.

Thank you for your assistance.