Whoops! Error: Could not read host and service status information!

3 posts / 0 new
Last post
KentC
Offline
Last seen: 7 years 3 months ago
Joined: 08.01.2014 - 22:49
Whoops! Error: Could not read host and service status information!

Hello,

 

I have the following issue: 

 

Software installed:

Nagios Core 4.0.2

Winrpe - 4.X

 

Problem:

 

I've tried all the different guides to using Winrpe to find the host and services when I place the different .cfg files under /etc/nagios/nagwin and on the remote machine it's installed like examples have shown with nrpe.cfg altered like itefix example. I've tried to get this to show up and nothing works! 

 

Can someone please help me with what I'm doing wrong, I've been checking for a few days with no luck. 

 

 

I'm willing to share whatever info out there to help server as a guide for the latest versions of each download to work. So far I can't get the hosts to show up unless I remove the main hosts.cfg and make it simple so only the WINPING portion works. 

 

Here are the guides I tried without success:

http://4sysops.com/archives/free-winrpe-nrpe-for-windows/

/content/nagwin-usage-example-2-basic-monitoring-windows-hosts

 

Kent C.

 

itefix
Offline
Last seen: 38 min 10 sec ago
Joined: 01.05.2008 - 21:33
The message indicates clearly

The message indicates clearly that your Nagwin services are not working. Please follow steps below for a recovery:

  • Stop all Nagwin services and uninstall Nagwin
  • Make sure that service account SvcNagwin is also removed
  • Make sure that four services are really deleted - They don't show up in the Services list
  • Remove remnants of tha installation directory.
  • Install Nagwin and start services from Nagwin start menu (as Administrator!)
  • Make sure that web interface displays monitoring 12 services for local host
KentC
Offline
Last seen: 7 years 3 months ago
Joined: 08.01.2014 - 22:49
Thank you tk! I'll give this

Thank you tk! I'll give this try today @ work and reply with my results.

 

 

Kent C.