Unable to move files on and off a windows 2008 r2 server

4 posts / 0 new
Last post
itservices
Offline
Last seen: 2 years 6 months ago
Joined: 25.07.2012 - 11:29
Unable to move files on and off a windows 2008 r2 server

Hi .. I have a bash script running on a 32bit red hat linux server that connects to a 32bit windows 2003 server running copssh (2.1.3) and then either picks up or drops off files. This has been running happily for several years without any problem.

Now I want to run the same script but connecting to a 64 bit windows 2008 r2  server running copssh (2.4.0) .... the user account is a local one on the windows server onto which i import the public key of the red hat server.

What I am seeing is that the script connect but then drops without any files moving either way. The destination directory is open to EVERYONE (read/write)  and if I connect manually I am able to move files but not via the script.

Is there a problem when connecting from a 32bit RH server to a 64bit windows server .. have the commands changed? .. does anyone have any ideas as Im totally stumped.

Steve

 

 

itefix
Online
Last seen: 10 min 13 sec ago
Joined: 01.05.2008 - 21:33
Please check if the service

Please check if the service account has proper permissions/rights - check our FAQ about the issue. Pay special attention to SeCreateTokenPrivilege user right.

itservices
Offline
Last seen: 2 years 6 months ago
Joined: 25.07.2012 - 11:29
User rights

I checked all of these and they were all correct. Is there any difference between the keys generated on the older versions and the new one ?? ... as this seems to be a problem with the Linux server dropping the connection to the windows server. The windows server is holding the keys from the Linux server under the user account but they are several years (and versions of copssh) old now.??

or could the switch from 32bit to 64bit be the problem ??

Steve

 

itefix
Online
Last seen: 10 min 13 sec ago
Joined: 01.05.2008 - 21:33
I can't whether key age or

I can't see whether key age or platform architecture being a problem - if it worked with an older version of Copssh, it should also work now. Seeing you being a customer, you may register a support ticket and send to us log results from both sides. There must be some error message somewhere.