Sync never finished and cause high cpu utilization

5 posts / 0 new
Last post
itefix
Offline
Last seen: 50 min 13 sec ago
Joined: 01.05.2008 - 21:33
Sync never finished and cause high cpu utilization

cwRsync VERSION 1.2.8, The sync is started without any problem and sync for couple of minutes, but unable to finish (looks like it's working but nothing is being copied)In addition the rsync procees cause 100% utilization at the destination server.

Please help

itefix
Offline
Last seen: 50 min 13 sec ago
Joined: 01.05.2008 - 21:33
Re: Sync never finished and cause high cpu utilization

Can you try the last version and see if it solves the problem ?

itefix
Offline
Last seen: 50 min 13 sec ago
Joined: 01.05.2008 - 21:33
Re: Sync never finished and cause high cpu utilization

I tried the last version, but the same happend.I moticed that even though I've uninstalled cwRsync, the service remains and wasnt deleted (even after restart ...)

itefix
Offline
Last seen: 50 min 13 sec ago
Joined: 01.05.2008 - 21:33
Re: Sync never finished and cause high cpu utilization

I tried the last version, but the same happend.I moticed that even though I've uninstalled cwRsync, the service remains and wasnt deleted (even after restart ...)

You can increase logging level by using -v switch.

You can remove the service completely by using following command :

cygrunsrv -R RsyncServer

itefix
Offline
Last seen: 50 min 13 sec ago
Joined: 01.05.2008 - 21:33
Re: Sync never finished and cause high cpu utilization

I too have seen exactly this.. I'm using the latest cwRsync. Both client and server are Win2K SP4. The client displayed
rsync: failed to set times on "/tmpdirname" (in ModuleName):No more files (89)

just before the server went to 100%. This happened just as the client was syncing a directory that co-incidentally contains temporary that get deleted every few seconds... Also I've only seen this occur over SSH, maybe only because of the additional delay, but am still testing.

If anyone has any clinet/server parameters that might help I'd be obliged. I have read the MAN pages to no avail. My flags for the client are -rt, I could take the t off for testing but we really need the time stamps to be carried over. TIA

Topic locked