NT/2000 login failed

13 posts / 0 new
Last post
itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
NT/2000 login failed

HelloThank you very much for copssh
I installed it on win2k3 and it worked flawlessly, but on win2k (i've tried 2) all i got is authentication failed (event log says the same). i feel it is even not passing the authen. to windows as i got policies to disable account after 3 logins, but even after say 20 tries the account is not locked out.
I use the last copssh (1.3.2)
Thanks again
gaiaphil

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Hi,Thanks for your feedback.

Hi,
Thanks for your feedback. You're right. I got the same problem when I tried copSSH 1.3.2 on windows NT/2000 systems. Version 1.3.1a works just fine. I think a small glitch has found its way into the installer package. I am investigating this issue.

Workaround in the meantime is to install copssh 1.3.1a. Older versions of copssh can be downloaded from here.

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

I've found that the problem is newer version of cygwin1.dll (1.5.17). The problem disappears when I switch back to the version 1.5.14, which comes with copSSH 1.3.1. I suppose that this is a cygwin issue. I will report it to the cygwin mailing list.
We have two workarounds:

  • Install copSSH 1.3.2 and replace cygwin1.dll with the previous one
  • Install copSSH 1.3.1a on Windows NT/2000 machines.
itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

Hi,
copSSH 1.3.2 was the first version i tried and i was confused not to get it to work, until i saw this thread.
Replacing cygwin1.dll (1.5.17) by cygwin1.dll (1.5.14)worked!!

I love this package. It seems to be the only package for Windows, which is (still) supported! The SSHWindows project seems to be dead.(last version July 9, 2004)

Keep up the good work!

[quote="support"]I've found that the problem is newer version of cygwin1.dll (1.5.17). The problem disappears when I switch back to the version 1.5.14, which comes with copSSH 1.3.1. I suppose that this is a cygwin issue. I will report it to the cygwin mailing list.

We have two workarounds:

  • Install copSSH 1.3.2 and replace cygwin1.dll with the previous one
  • Install copSSH 1.3.1a on Windows NT/2000 machines.

[/quote]

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

I ran into this same problem with 1.3.2. I have replaced the cygwin1.dll with version 1.5.14, but I continue to have the same problem.
No log is currently being saved to /var/log/copSSHD.log

Here is the log from putty on the client machine:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2005.06.06 13:21:21 =~=~=~=~=~=~=~=~=~=~=~=
login as: administrator
administrator@diamond's password:
Access denied
administrator@diamond's password:
Access denied

Any suggestions?

Sincerely,

Jon Roberts
Restaurant eFund

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

Interesting! A simple question : Did you restart the service after having replaced cygwin1.dll ?

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

Yes,
Restarted the service. User is a domain user if that makes any difference. I used the scripts that you posted here to add the user and I verified that the group and passwd do indeed contain the correct usernames and groups with the correct ssids.

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

Hello dear Site AdminThank you for the help.
Well after applying the hack you've suggested i can pass the authentication, but i got the following message:
"
bash.exe: warning: could not find /tmp, please create!
-bash: /etc/profile: Permission denied
-bash: /home/myuser/.bash_profile: Permission denied
-bash-2.05b$
"
and with sftp i got just "connection closed"

Same thing with 1.3.1a

Thanks again Gaiaphil

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

It seems to me that there is something wrong with your installation. /tmp directory is created automatically by the installer. Create tmp directory and run setperms.cmd again. You may have to reinstall copssh if it doesn't help.
[quote="gaiaphil (GUEST)"]Hello dear Site Admin
Thank you for the help.
Well after applying the hack you've suggested i can pass the authentication, but i got the following message:
"
bash.exe: warning: could not find /tmp, please create!
-bash: /etc/profile: Permission denied
-bash: /home/myuser/.bash_profile: Permission denied
-bash-2.05b$
"
and with sftp i got just "connection closed"

Same thing with 1.3.1a

Thanks again Gaiaphil
[/quote]

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

I keep geting a similar error on rsync v2:Logon Failure:
Reason: Unknown user name or bad password
User Name: NOUSER
Domain:
Logon Type: 2
Logon Process: Advapi
Authentication Package: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0

I only have version 5.17.129 that was included with the install can someone post a link to a older version of cygwin1.dll?

Thanks,

Andrew

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

I've discovered that Users must have read access to the installation directory. This is automatically handled by v1.3.1. I am going to reintroduce it again with the next release (1.3.3). The problem with cygwin 1.5.17 still exists. Therefore, the new release will have two separate installers for XP/2003 and 2000/NT systems.

[quote="Jon Roberts (GUEST)"]Yes,

Restarted the service. User is a domain user if that makes any difference. I used the scripts that you posted here to add the user and I verified that the group and passwd do indeed contain the correct usernames and groups with the correct ssids.
[/quote]

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

copSSH 1.3.3 is released now and is supposed to solve this problem.

itefix
Online
Last seen: 1 min 30 sec ago
Joined: 01.05.2008 - 21:33
Re: NT/2000 login failed

Resolved it for me.
Thanks!

Topic locked