installer does not install service?

9 posts / 0 new
Last post
itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
installer does not install service?

crRsync V1.3's installer does not install the daemion as NT Service on my Win2000 server box? Is it supposed to do this by simply running the installer, or is manual configuration required to install the service?

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer doe snot install service?

Hi,
The cwRsync installer installs rsync daemon as a service called RsyncServer. After a successful installation, you should see it in the Services list.

By default, the service is set up to be started manually.

Rgrds Tev

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer doe snot install service?

Does this install a full version of cygwin or is it just some dll's? Could you give more detail on what's installed. Thanks.

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer doe snot install service?

It is not a complete cygwin installation. Following files are copied (as of version 1.3.0a):

rsync.exe, ssh.exe, ssh-keygen.exe, cygwin1.dll, cygcrypto-0.9.7.dll, cygminires.dll, cygpopt-0.dll, cygz.dll

In addition, rsync daemon is set up as a service and some permission arrangements are made.

Rgrds Tev

NB! Even if the list above shows the basic operations, what's happening inside the installer may vary from version to version.

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer doe snot install service?

The service is not being installed on my Win 2003 server either. Install completes but there is no "RsyncServer" service.

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer doe snot install service?

Setup will be disturbed if you already have active processes using cygwin. Make sure that this is not the case. The last version (2.0.0) has better handling of existing cygwin installations. Can you try if it helps ?

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer doe snot install service?

I too am having this problem on an XP SP2 machine.
I had previously installed a beta copy of cwrsync server emailed to me by the author a little over a week ago. It ran without issue. I uninstalled it, then a few days later went to install the final version of 2.0.0. First, the installer wouldn't allow me to conitnue withour removing this key:

HKLM\Software\Cygnus Solutions\Cygwin\mounts v2

Once I did, the program went thru the motions of installing, but it did not install either SSH or Rsyncd service. Any ideas?

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer doe snot install service?

I made a new cwrsync server 2.0.0+ installer with extensive logging. You can grab it here.

Checksums:
MD5 - c6908c9e920b8566ab4e5ce0f33d777d *cwRsync_Server_2.0.0_log_Installer.zip
SHA1 - a7fcf829293884075d8365c9a611d6989d979e56 *cwRsync_Server_2.0.0_log_Installer.zip

I hope it helps to locate the problem.

itefix
Offline
Last seen: 17 hours 26 min ago
Joined: 01.05.2008 - 21:33
Re: installer does not install service?

Using the installer with extensive logging, I was able to see the problem was the password for the SvcwRsync account didn't meet the minimum password requirements for the domain. The account wasn't created, and everything else was downhill from there. I finally got it to install. I had to change the following policies:
* Disabled "Password must meet complexity requirements"
* Set "Enforce Password History" to zero (because of previous cwRsync installs using same passwd)
* Set minimum password length to 7

Topic locked