HELP WITH NEW INSTALLATION

5 posts / 0 new
Last post
MichaelDunn
Offline
Last seen: 7 years 9 months ago
Joined: 21.12.2012 - 01:02
HELP WITH NEW INSTALLATION

Hello all, 

 

Please bear with me as I am new to this program and it's Linux based commands/file paths. I have installed Nagwin 1.3.0, the free version, on a Windows Server 2008 R2 machine. I have also installed winrpe 2.12 on a Windows Server 2003 machine within the same subnet. I have follow the directions listed in this page to the 'T'; /content/nagwin-usage-example-2-basic-monitoring-windows-hosts and after I restart the services, go back to the webpage and select "Hosts", I am presented with:


"Whoops!

Error: Could not read object configuration data!

Here are some things you should check in order to resolve this error: 

  1. Verify configuration options using the -v command-line option to check for errors. 
  2. Check the Nagios log file for messages relating to startup or status data errors. 

Make sure you read the documentation on installing, configuring and running Nagios thoroughly before continuing. If all else fails, try sending a message to one of the mailing lists. More information can be found at https://www.nagios.org/. "

 

 

I also selected the "Check Nagios Configuration" batch file and this is what returns. 

 

"Check Nagios Configuration 

Thu 12/20/2012 

06:14 PM

 

Nagios Core 3.3.1

Copyright (c) 2009-2011 Nagios Core Development Team and Community Contributors

Copyright (c) 1999-2009 Ethan Galstad

Last Modified: 07-25-2011

License: GPL

 

Website: http://www.nagios.org

Reading configuration data...

   Read main config file okay...

Warning: Could not set effective UID=1006

   Failed to drop privileges.  Aborting.

 

***> One or more problems was encountered while processing the config files...

 

     Check your configuration file(s) to ensure that they contain valid

     directives and data defintions.  If you are upgrading from a previous

     version of Nagios, you should be aware that some variables/definitions

     may have been removed or modified in this version.  Make sure to read

     the HTML documentation regarding the config files, as well as the

     'Whats New' section to find out what has changed."

 

 

PLEASE HELP!! I know it is some very small detail that I am missing, but I am having a really hard time finding it. THANKS!!!


 
 

itefix
Offline
Last seen: 16 hours 36 min ago
Joined: 01.05.2008 - 21:33
You have probably some

You have probably some configuration issues. Try to run 'Check Nagios Configuration' as administrator (right click - run as administrator). You need also make sure that your Configuration files are saved in Unix format. You can either use an editor capable of if or edit one the existing configuration files in WordPad and save them as new configuration files.

MichaelDunn
Offline
Last seen: 7 years 9 months ago
Joined: 21.12.2012 - 01:02
TK,  Thank you for the quick

TK, 

Thank you for the quick response. I went ahead and ran the 'Check nagios Configuration' batch file as administrator, but I received the same results as above. Also, when I saved my configuration files, I saved them as .cfg files (just like how it says in the link above). How to I make sure they are in true Unix format to hopefully resolve this issue? As soon as I add the .cfg file to ICW/etc/nagios/nagwain I receive the Whoops error message. As soon as I remove that .cfg file, it goes away. Obviously, something regarding my .cfg file is messing me up and I can't figure out why. 

 

I really appreciate all the help! Thanks!

itefix
Offline
Last seen: 16 hours 36 min ago
Joined: 01.05.2008 - 21:33
Try steps below:   Open a

Try steps below:

 

  • Open a bash prompt by running <inst.dir>\bin\bash.exe
  • Issue following commands:

mkpasswd > /etc/passwd

mkgroup > /etc/group

This will probably solve problems with checking nagios configuration via start menu

  • Use d2u (dos-to-windows) tool to convert your configuration files from windows to unix:

cd <your config directory>

d2u <your config file>

MichaelDunn
Offline
Last seen: 7 years 9 months ago
Joined: 21.12.2012 - 01:02
This resolved my

This resolved my issue.

 

Thanks!!