cwRsync Server v2 won't install

7 posts / 0 new
Last post
itefix
Offline
Last seen: 41 min 31 sec ago
Joined: 01.05.2008 - 21:33
cwRsync Server v2 won't install

Hi,
The v2 of the server won't install because it claims that there is an existing cygwin installation or some application that is dependent upon cygwin.

Where can I find a list of the files / registry entries that the installer is checking for ... so I can remove them?

Cheers,
Vaughan

itefix
Offline
Last seen: 41 min 31 sec ago
Joined: 01.05.2008 - 21:33
Re: cwRsync Server v2 won't install

I'd already asked the question in another thread, and got a response from support saying...
Installer checks if registry key HKLM\Software\Cygnus Solutions\Cygwin\mounts v2 exists. You can remove it, if you are sure that there is no other cygwin-stuff on your machine.

...which worked.

But, I'm finding that the install works partially before complaining about not being able to update several files in the install directory. And the install directory itself doesn't have an owner, so you then have to assign one before removing it - very strange.

Good luck in finding a solution - I can't wait til it works.

itefix
Offline
Last seen: 41 min 31 sec ago
Joined: 01.05.2008 - 21:33
Re: cwRsync Server v2 won't install

Hi,
I wrote a FAQ about the issue. I hope that it will clarify what pre-conditions exist and how they are handled.

When it comes to directory permissions and partial setup, try to find batch file setperms.cmd and run it again. That will help to stabilize the directory.

Rgrds Tev

itefix
Offline
Last seen: 41 min 31 sec ago
Joined: 01.05.2008 - 21:33
Re: cwRsync Server v2 won't install

Thanks guys, the FAQ was exactly what I needed

itefix
Offline
Last seen: 41 min 31 sec ago
Joined: 01.05.2008 - 21:33
Re: cwRsync Server v2 won't install

Hello,
On a Windows NT 4.0 server (which hopefully lives its last weeks ;-) I cannot install the server.
Have checked the FAQ, and removed offending files and registry entries, but the installer still complains about the cygwin DLL being opened by "" (empty space)...

Any idea?

By the way, a lot of thanks to all the people behind this GREAT piece of software!!!

itefix
Offline
Last seen: 41 min 31 sec ago
Joined: 01.05.2008 - 21:33
Re: cwRsync Server v2 won't install

Did anybody get the cygwin server 2.0 to install on nt4? Getting the same problems as Jean-Christophe. Would like to install it, because shares over on linux box are really slow under samba to rsync...
Sean

itefix
Offline
Last seen: 41 min 31 sec ago
Joined: 01.05.2008 - 21:33
Re: cwRsync Server v2 won't install

I have verified that cwRsync server installer doesn't work on NT systems. The logic that checks if there are cygwin-dependent processes is broken on NT.

I have created a temporary installer without that logic and verified that it works on NT. It can be downloaded here.

Checksums:
MD5 - 13d75449a79a6ae7aa7c7aa93423ad32 *cwRsync_Server_2.0.0-ntonly_Installer.zip
SHA1 - 13d75449a79a6ae7aa7c7aa93423ad32 *cwRsync_Server_2.0.0-ntonly_Installer.zip

This bug will be corrected in the next release.

Rgrds Tev

Topic locked