Copssh running under Windows XP doesn't allow remote host to logoff properly

3 posts / 0 new
Last post
tpurdy
Offline
Last seen: 9 years 2 months ago
Joined: 03.12.2011 - 00:00
Copssh running under Windows XP doesn't allow remote host to logoff properly

With Copssh running on my Windows XP machine, exiting the remote client hangs the command shell in which I am running the client.  I can then force the completion of the logoff by opening the Copssh control panel on the XP, displaying active connections, and terminating any running process(es).  Attached is the log of connecting the client via public/private key, then exiting (debug3 is turned on).  The same client works fine connecting to Copssh running on my Windows 7 machine; it always exits normally.

Could this problem be corrected via an entry in the server or client configuration file?

Thanks, ...Tom

2012.04.08 14:07:31 -  debug2: channel 0: close_read
2012.04.08 14:07:31 -  debug2: channel 0: read failed
2012.04.08 14:07:31 -  debug2: channel 0: read<=0 rfd 8 len 0
2012.04.08 14:07:31 -  error: chmod /dev/tty0 0666 failed: No such file or directory
2012.04.08 14:07:31 -  error: chown /dev/tty0 0 0 failed: No such file or directory
2012.04.08 14:07:31 -  debug1: session_pty_cleanup: session 0 release /dev/tty0
2012.04.08 14:07:31 -  debug2: channel 0: output open -> closed
2012.04.08 14:07:31 -  debug2: channel 0: send eow
2012.04.08 14:07:31 -  debug2: channel 0: close_write
2012.04.08 14:07:31 -  debug2: channel 0: write failed
2012.04.08 14:07:31 -  debug1: session_exit_message: release channel 0
2012.04.08 14:07:31 -  debug2: channel 0: request exit-status confirm 0
2012.04.08 14:07:31 -  debug1: session_exit_message: session 0 channel 0 pid 2296
2012.04.08 14:07:31 -  debug1: session_by_pid: pid 2296
2012.04.08 14:07:31 -  debug1: Received SIGCHLD.
2012.04.08 14:07:27 -  debug1: permanently_set_uid: 1005/513
2012.04.08 14:07:27 -  debug2: fd 6 setting O_NONBLOCK
2012.04.08 14:07:27 -  debug2: fd 8 setting O_NONBLOCK
2012.04.08 14:07:27 -  debug2: channel 0: rfd 8 isatty
2012.04.08 14:07:27 -  debug2: fd 3 setting TCP_NODELAY
2012.04.08 14:07:27 -  debug1: session_input_channel_req: session 0 req shell
2012.04.08 14:07:27 -  debug1: session_by_channel: session 0 channel 0
2012.04.08 14:07:27 -  debug1: server_input_channel_req: channel 0 request shell reply 1
2012.04.08 14:07:27 -  debug1: session_pty_req: session 0 alloc /dev/tty0
2012.04.08 14:07:27 -  debug1: Allocating pty.
2012.04.08 14:07:27 -  debug1: session_input_channel_req: session 0 req pty-req
2012.04.08 14:07:27 -  debug1: session_by_channel: session 0 channel 0
2012.04.08 14:07:27 -  debug1: server_input_channel_req: channel 0 request pty-req reply 1
2012.04.08 14:07:27 -  debug1: server_input_global_request: rtype no-more-sessions@openssh.com want_reply 0
2012.04.08 14:07:27 -  debug1: server_input_channel_open: confirm session
2012.04.08 14:07:27 -  debug1: session_open: session 0: link with channel 0
2012.04.08 14:07:27 -  debug1: session_open: channel 0
2012.04.08 14:07:27 -  debug1: session_new: session 0
2012.04.08 14:07:27 -  debug2: session_new: allocate (allocated 0 max 10)
2012.04.08 14:07:27 -  debug1: channel 0: new [server-session]
2012.04.08 14:07:27 -  debug1: input_session_request
2012.04.08 14:07:27 -  debug1: server_input_channel_open: ctype session rchan 0 win 1048576 max 16384
2012.04.08 14:07:27 -  debug1: server_init_dispatch_20
2012.04.08 14:07:27 -  debug2: fd 5 setting O_NONBLOCK
2012.04.08 14:07:27 -  debug2: fd 4 setting O_NONBLOCK
2012.04.08 14:07:27 -  debug1: Entering interactive session for SSH2.

itefix
Offline
Last seen: 16 min 53 sec ago
Joined: 01.05.2008 - 21:33
Have a look at a related

Have a look at a related forum topic about the issue. There are several approaches to keep the problem under control.

itefix
Offline
Last seen: 16 min 53 sec ago
Joined: 01.05.2008 - 21:33
No responses so far.

No responses so far.