Start error Windows2003

13 posts / 0 new
Last post
itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Start error Windows2003

Hi !
I installed the latest version of the cwrsync-server on a windows2003 Server (German version).

The install-log and process seems fine. When I want to start the service, always appears the error 1067 (unexpected ending..).

The Task-Mananger shows a task rsync.exe ownend by the account created at the setup-process. rsync from a linux client runs .... and the files are copied.

Really a problem or just another windows-error nobody knows ?

regards
mike

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

How does the event log look like ? Do you see any odd entries ?

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

Sorry, nothing special:
only the entry, that RsyncServer was terminatet unexpectly, that happens the xx time ...

in the task manager there is a task rsync.exe which is running ..

I installed cwrsync-server on a second machine, which is ident in Hardware and Software > same result...

But it seems that the rsync-server works fine, there is only a problem, that the server deletes only files in the "root"-directory from the rsync-script command (like home/test all files in "test" are deleted if they are so in the source, but not in subdirectories (with options avz --delete - i think that they are right?)

Any idea ?

TX and regards
mike

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

It seems that the part of the installation where setting permissions on the directories might go wrong, because of the localized OS.

Could you publish contents of the batch file setperms.cmd and the output from listacc command ?

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

output of listacc:
SET LISTACC_ADMUSER=Administrator
SET LISTACC_ADMGROUP=Administratoren
SET LISTACC_USRGROUP=Benutzer

content of setperms.cmd

ECHO OFF
REM Set default values for standard user/group names
SET LISTACC_ADMUSER=Administrator
SET LISTACC_ADMGROUP=Administrators
SET LISTACC_USRGROUP=Users
REM Localize standard user/group names
"C:\Programme\cwRsyncServer\bin\listacc" > "C:\Programme\cwRsyncServer\_tmp2.cmd"
call "C:\Programme\cwRsyncServer\_tmp2.cmd" > NUL
"C:\Programme\cwRsyncServer\bin\subinacl" /noverbose /file "C:\Programme\cwRsyncServer" /setowner=SvcwRsync > NUL
"C:\Programme\cwRsyncServer\bin\subinacl" /noverbose /subdirectories "C:\Programme\cwRsyncServer\*" /setowner=SvcwRsync > NUL
"C:\Programme\cwRsyncServer\bin\xcacls" "C:\Programme\cwRsyncServer" /T /G %LISTACC_ADMGROUP%:F /Y > NUL
"C:\Programme\cwRsyncServer\bin\xcacls" "C:\Programme\cwRsyncServer" /T /E /G SvcwRsync:F /Y > NUL

lg
Michael

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

Everything seems normal. What I wonder if you used Prep a Dir for Upload wizard. This wizard makes necessary arrangements to give rsync service account access to directories behind rsync modules.

Make sure that rsync service account has full permissions on your target directory tree.

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

I did some tests on both machines.
The error is ident: Start of service is quited unexpectly; but the service runs and works ...

The cwrsync account has all permissions it needs. If I delete the account or give less permissions, the rsync-task from the other machines is not possible.

The only problem is, that the files in subdirectories of the tree are not deleted, if they are so in the source (if the are changed, they are also changed in the subdirectories).
This happens only if the rsync-task is started from linux to the windows-server. If a windows-client rsync-task sync's to windows, all works fine. The options are the on the windows-side (-avz --delete) on the linux-side (-avzR --delete). I don't know, why the R is necessary, but if not, the task don't work.
But this seems to be an other problem which don't depend on the error-messages described above.

Any ideas?

TX and greetings

Mike

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

What rsync version do you use on Linux side ?

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

rsync 2.6.4 protocol 29 on linux sidersync 2.5.1 protocol 25 on windows side

greetings
mike

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

I am a little bit confused then. Version 2.5.1 is very old. None of the cwrsync packages has an rsync so old. I recommend to upgrade to latest cwrsync version and see if it solves your problem.

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

The problem is: with the old version all works fine !
only if I sync from Linux to windows-side the problem happens

greetings
mike

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

What I wonder if higher protocol version (29) on sender side (linux)creates some problems on the receiver side (windows, protocol 25).

itefix
Offline
Last seen: 9 hours 46 min ago
Joined: 01.05.2008 - 21:33
Re: Start error Windows2003

it seems, that is was a bug on the linux-side in 2.6.4. After updating to 2.6.6 the problems are solved !
greetings
Mike

Topic locked